В июне появилась новая десятая версия популярного движка DataLife Engine (или сокращенно DLE). Но также осталось множество классных шаблонов, созданных для версии 9.8. И если Вы уже установили последнюю версию скрипта, а шаблон выбрали совместимый с предыдущей версией, тут возникает вполне ожидаемый вопрос — как адаптировать шаблон DLE 9.8 под DLE 10? Об этом и расскажет сегодняшняя статья.

Адаптируем шаблоны DLE 9.8 под DLE 10

На самом деле все предельно просто, Вам необходимо будет выполнить всего лишь одно действие с кодом шаблона. Откройте файл addnews.tpl в Вашем любимом html-редакторе и найдите следующий код:

<tr>
        <td class="label">
                Категория:<span class="impot">*</span>
        </td>
                <td>{category}</td>
</tr>

Ниже добавьте этот код:

<tr>
                <td class="label">&nbsp;</td>
                <td><a href="#" onclick="$('.addvote').toggle();return false;">Добавить опрос</a></td>
        </tr>
        <tr  class="addvote" style="display:none;" >
                <td class="label">Заголовок опроса:</td>
                <td><input type="text" name="vote_title" value="{votetitle}" maxlength="150" class="f_input" /></td>
        </tr>
        <tr  class="addvote" style="display:none;" >
                <td class="label">Вопрос:</td>
                <td><input type="text" name="frage" value="{frage}" maxlength="150" class="f_input" /></td>
        </tr>
        <tr  class="addvote" style="display:none;" >
                <td class="label">Варианты ответов:<br /><br />Каждая новая строка является новым вариантом ответа</td>
                <td><textarea name="vote_body" rows="10" class="f_textarea" >{votebody}</textarea><br /><input type="checkbox" name="allow_m_vote" value="1" {allowmvote}> Разрешить выбор нескольких вариантов</td>
</tr>

На этом все. Теперь Ваш шаблон полностью совместим с DLE 10.